KCS Troubleshooting
Symptom
- Agents don't have up to date information
Cause
- Knowledge is out of date
Fix
Analysis:
Knowledge-Centered Service (KCS) describes a way of interacting with knowledge which enables teams to:
- answer questions quickly,
- deliver answers where people are looking for them,
- and train new employees faster.
Additionally, KCS provides insight into which questions are being asked the most, and identifies recurring problems so we can remove them from the environment.